Your Freedom - HOMENEWSDOWNLOADSACCOUNTDOCS & FAQFORUMS

 

Latest News

10-09-19

YF back on Google Play

We have been able to resolve the issues with Google and YF is again available on Google Play. You ca...

01-02-19

Bitcoin payments available again

We have been able to fix the Bitcoin payment issue, and you should now be able again to pay with Bit...

22-01-19

New login on web page

We have changed the way you log in to the web site -- just in case you are wondering. The old way wa...

 
Sin iniciar sesión.
    20-08-08

  • New client version 20080820-01 available
  • A new version of the Your Freedom client has been released, it's called 20080820-01.

    The most important change is that this is the first release that is no longer compatible with Java 1.4 and Java 5 -- you need Java 6 or newer (in fact there is a newer version if you're wondering: it's called Java 6 Update 10 RC and is actually a Java 7 beta). For those who cannot install Java 6 on their PCs we still got version 20080815-01 around -- the last version compatible with older Java versions.

    Why, you might ask, are you moving away from Java 1.4 and Java 5? Simply because our users are moving away from old operating systems and are expecting us to support the latest ones. Unfortunately, Java 1.4 and Java 5 have no native support for system trays; we've worked around this in the past by bundling additional software but that breaks compatibility with 64 bit systems and it didn't work on OS X or KDE either. Given that Java 7 is in the starting blocks (oops -- I should not be watching the Olympics while working) we feel that this is not an undue requirement.

    Please bear with us if the systray stuff is not working smoothly yet -- actually, the native Java implementation is not exactly behaving well out of the box and we had to use a few kludges.

     

 
   Acceptable Use  | Data Protection Statement